Cocoapods 下载库时的警告

stackoverflow 上有类似的回答,但是没有能解决我的问题。

[!] The `SherryWeather [Debug]` target overrides the `EMBEDDED_CONTENT_CONTAINS_SWIFT` build setting defined in `Pods/Target Support Files/Pods-SherryWeather/Pods-SherryWeather.debug.xcconfig. This can lead to problems with the CocoaPods installation - Use the `$inherited` flag, or - Remove the build settings from the target. [!] The `SherryWeather [Release]` target overrides the `EMBEDDED_CONTENT_CONTAINS_SWIFT` build setting defined in `Pods/Target Support Files/Pods-SherryWeather/Pods-SherryWeather.release.xcconfig. This can lead to problems with the CocoaPods installation - Use the `$inherited` flag, or - Remove the build settings from the target.

加一句
inhibit_all_warnings!
试试看

Swift项目使用CocoaPods时,Podfile文件中,在platform :ios, 8.0一行下需要有一行use_frameworks!。你试一下。

发表评论

电子邮件地址不会被公开。 必填项已用*标注